Our teams have identified the root cause of the delays affecting ocean tracking data updates and have applied corrective measures. The system is now processing data again and we are closely monitoring to confirm full recovery.
The data pipeline is processing normally and the backlog of ocean tracking updates is being progressively cleared.
We expect full recovery shortly and will post a final update once confirmed. No data has been lost.
Posted Jul 23, 2026 - 16:28 CEST
Identified
We are currently experiencing delays in the processing of ocean tracking data for some shipments tracked with EDI315. Tracking milestones and status updates may appear later than usual.
Our teams are actively investigating the root cause, which has been traced to a performance issue with a third-party file transfer service. No data is being lost — all updates will be processed once the issue is resolved.
Posted Jul 23, 2026 - 09:06 CEST
This incident affects: Ocean features (Events Tracking).