This incident has been resolved. Ocean shipment tracking updates are now fully operational and all delayed data has been successfully processed — no information has been lost.
We apologize for the disruption experienced between July 16 and July 20, and thank you for your patience.
Posted Jul 20, 2026 - 13:55 CEST
Monitoring
We have identified and resolved the root cause of the delays affecting ocean shipment tracking updates.
A fix was deployed earlier today and tracking data is now being actively processed. You may still notice some residual delays as we work through the backlog of updates. No tracking data has been lost, and all information will be fully restored.
We expect tracking to return to normal progressively over the coming hours. We will confirm once the service is fully back to normal.
We apologize for the disruption and thank you for your patience.
Posted Jul 20, 2026 - 13:37 CEST
Investigating
We are currently experiencing an issue affecting the real-time tracking updates for ocean shipments since 16/07. As a result, some tracking information may not reflect the latest status and could appear outdated or delayed.
All shipment data is being safely stored. No data has been lost.
Our teams are actively working on a fix, and tracking updates will be restored and back-filled once resolved.
We apologize for the inconvenience and will provide a further update within the next hour.
Posted Jul 20, 2026 - 11:16 CEST
This incident affected: Ocean features (Events Tracking).